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РЕДАКТОР ЛИТОГРАФИЧЕСКИХ СТРУКТУР 

GDB файл 

Редактор NanoMaker предназначен для создания и редактирования много-
уровневых иерархических литографических структур. Созданные литографи-
ческие структуры сохраняются в файлах данных с расширением *.GDB. Фор-
мат GDB файла был специально разработан для эффективного хранения и 
доступа к существенной информации о литографических структурах. Данные 
в GDB файле сохраняются в бинарной форме. В дальнейшем GDB файл и ли-
тографическая структура будут являться синонимами. 

Основной конструкционной единицей литографической структуры и GDB 
файла, соответственно, является именованная Структура (Structure). Каждый 
GDB файл может включать одну или большее количество структур. Каждая из 
структур, в свою очередь, состоит из набора геометрических объектов - Эле-
ментов (Element) расположенных на плоскости. 

Разрешение (Resolution) 

Каждый GDB файл характеризуется параметром Разрешение (Resolution). 

Разрешение это наименьший шаг курсора редактора, который может быть ис-
пользован при создании элементов. Кроме того, от величины Разрешения за-
висят максимальные габариты Структуры. Разрешение должно быть опреде-
лено в момент создания GDB файла. По умолчанию новый файл создается с 
Разрешением 1 нм. Габариты Структур в таком файле ограничены размерами 
от -1000 мм до 1000 мм. При выборе величины Разрешения руководствуйтесь 
тем правилом, что величина Разрешения должна быть, по крайней мере, на 
порядок лучше минимального размера проектируемых элементов, что позво-
лит обеспечить достаточную точность их проектирования. После создания 
GDB файла Разрешение в нем не может быть изменено. Если все-таки разре-
шение при проектировании структуры необходимо повысить, создайте новый 
файл с более высоким разрешением и скопируйте в него уже созданные эле-
менты. 

Структуры (Structures) 
Каждая структура должна иметь имя. Имя структуры в пределах файла GDB 
должно быть уникальным. Длина имени ограничена 255 символами. Имя 
структуры может быть образовано буквами латинского алфавита, цифрами и 
некоторыми другими символами. Имена структур задаются с учетом регистра 
букв. Т.е. в одном файле могут существовать две разных структуры, одна из 
которых может называться, например, a1, а другая A1. 

При создании GBD файла, по умолчанию, создается одна структура с именем 
MAIN. Эта структура не может быть ни удалена из файла, ни переименована. 
По мере необходимости в GDB файл могут быть добавлены дополнительные 
структуры. Максимальное их число не может превысить 32767 (215-1). 

Элементы (Elements) 
В настоящий момент в формате GDB файла существует восемь типов элемен-
тов. Три из них базовые - Point, Line и Contour (Polygon). Более специфиче-
скими элементами являются Time&Date, Comments, Structure reference, Dose 
map и Reference map, которые перед экспонированием приводятся к совокуп-
ности базовых элементов. Кроме того, для удобства проектирования сущест-
вует несколько производных от Contour элементов, которые преобразуются в 
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контуры немедленно после завершения ввода. К ним относятся: Rectangle, 
Ring, Circle, Text. 

Базовые элементы задаются соответствующим набором координат и характе-
ризуются следующими атрибутами: Доза экспонирования (Dose), 3D атрибут 
(3D Attribute), Слой (Layer). Где, 

Доза экспонирования – относительная величина в процентах к чувстви-
тельности резиста (T/T0), показывающая во сколько раз время экспониро-
вания одной точки данного элемента отличается от времени экспонирова-
ния одной точки элемента со 100%-ой дозой,. Величина этого атрибута 
может варьироваться в пределах от 0% – 3200% с точностью 0.1%. Под-
робнее о чувствительности резистов см. HELP. 

3D атрибут - это признак, который актуален только для 3D структур, когда 
необходимо создать структуру с заданным трехмерным профилемю Он мо-
жет нести различный смысл в зависимости от поставленной задачи. На-
пример, 3D атрибут может задавать толщину остаточного резиста или ве-
личину фазового сдвига. В последнем случае, с помощью линейного пре-
образования атрибут может быть приведен к толщине резиста. Значение 
этого атрибута может варьироваться от -3200% - 3200% с точностью 
0,1%. 

Слой – величина определяет принадлежность данного элемента к одному 
из 256-ти слоев. Величина этого атрибута может варьироваться в диапа-
зоне 0 – 255. 

Специфические элементы обладают некоторыми дополнительными атрибута-
ми, которые будут перечислены ниже, при описании этих элементов. 

Слои 

Каждая структура может содержать 256 слоев (от 0-го до 255-го) и позволяет 
распределять элементы по этим слоям для технологических нужд, например 
для многослойной литографии с совмещениями слоев. 

3D атрибут 
Для создания трехмерной (3D) литографической структуры в GDB файле дол-
жен быть установлен 3D признак. 

Сетка разрезания (Database Cells) 

Для оптимизации решения некоторых задач, связанных с подготовкой к экс-
понированию или непосредственно с экспонированием, внутреннее простран-
ство структуры может быть разделено квадратной сеткой на ячейки. Шаг сет-
ки произвольный. Элементы структуры, пересекающиеся сеткой, разрезаются 
ею на отдельные элементы по границам сетки. При наличии сетки, все опера-
ции с элементами выполняются последовательно при обходе каждой из ячеек 
сетки. Сначала выполняются операции с  элементами внутри одной ячейки и 
уже только затем с элементами следующей ячейки.  Т.е. сетка организует по-
следовательность работы с элементами структуры. При экспонировании с пе-
реездами стола, разрезание структуры сеткой является обязательным. Сетка 
разрезания создает подполя (определяет их размеры), между которыми осу-
ществляются переезды. Сетка разрезания рисуется оранжевым цветом. 

Окно Редактора и Команды Меню 
При открытии существующего или создании нового GBD файла открывается 
как минимум одно окно - view, в котором отображается структура MAIN. Каж-
дая из содержащихся в GDB файле структур может быть открыта в отдельном 
окне для просмотра и редактирования. 
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Для того чтобы создать новый GDB файл выберите команду New Data Base… 
в меню File (File->New Database…). В диалоге New Database File оставьте 
все поля без изменений и нажмите кнопку OK. 

В новом файле существует только одна структура MAIN, которая изначально 
пуста, т.е. не включает ни одного элемента. 

В заголовке окна редактора присутствуют имя файла, имя структуры, атрибут 
пространственного измерения (2D или 3D) и порядковый номер окна, разде-
ляемые двоеточием, например как на Рис 1. 

 
Рис. 1. Главное окно программы внутри которого отрыты окна редактора, отображающие вновь 

созданные структуры MAIN и Second. 

При начальных установках параметров окна редактора в левом верхнем углу 
окна красным цветом изображается мерный отрезок (масштабная шкала), а 
пространство окна расчерчивается координатной сеткой, которая рисуется 
зеленым цветом. Через центр системы координат проходят две утолщенных 
линии, отмечающие положение осей координат. Шаг сетки всегда равен мер-
ному отрезку. 

Текущие координаты курсора, который в окне редактора всегда совмещен с 
указателем мыши, отображаются в двух редактируемых полях, лежащих на 
нижнем обрамлении главного окна программы. Эти координаты всегда пока-
зываются в микронах. Правее них, в следующем поле отображается шаг кур-
сора в соответствующих единицах измерения. В крайнем правом поле пока-
зывается количество селектированных элементов (см. Рис 1). 

Панель Инструментов (Toolbar) 

Слева, на обрамлении главного окна программы NanoMaker располагается 
панель Инструментов (см. Рис 1). На этой панели, в два вертикальных ряда 
располагаются кнопки для быстрого доступа к основным командам и диалогам 
программы (левый ряд) и к командам редактора (правый ряд). 

Масштаб 

При открытии окна масштаб выбирается таким, чтобы вся структура была 
видна полностью. В дальнейшем, при изменении масштаба отображения 
структуры, изменяется размер мерного отрезка и, соответствующим образом, 
изменяется шаг сетки. 

Для быстрого изменения масштаба используйте колесо мыши или клавиши / 
и * на цифровой клавиатуре. Обратите внимание, что увеличение или 
уменьшение отображаемого поля производится относительно текущего поло-
жения курсора. Таким образом, для удобства редактирования можно переме-



Редактор литографических структур   Руководство Пользователя 

www.nanomaker.com 8 

щать в центр окна различные участки дизайна структуры при этом увеличи-
вая или уменьшая масштаб отображения. 

Для того чтобы подвинуть отображаемый фрагмент структуры без изменения 
масштаба, нажмите левую кнопку мыши и, удерживая ее, переместите указа-
тель в нужное положение в окне и затем отпуститете кнопку. 

Для того чтобы увидеть всю структуру целиком, нажмите клавишу =. 

Шаг курсора 
Шаг курсора - это расстояние, на которое перемещается курсор в окне редак-
тора при нажатии на любую клавишу-стрелку. Шаг курсора может задаваться 
в широком диапазоне, который также зависит от Разрешения файла. Когда 
создается новый файл с Разрешением по умолчанию 1 нм, шаг курсора рав-
няется 1 мкм, что является достаточно удобным. 

Для быстрого изменения шага курсора используйте клавиши + и - на цифро-
вой клавиатуре. 

Для того чтобы точно переместить курсор в ближайший узел координатной 
сетки, например при создании нового элемента, нажмите клавишу Shift. 

Режим показа элементов 

Редактор NanoMaker поддерживает несколько режимов отображения элемен-
тов. 

Режим показа контуров 

По-умолчанию, при открытии окна редактора всегда устанавливается ре-
жим показа контуров-слоев. В этом режиме элементы в видимых слоях 
отображаются в виде разноцветных обрамляющих контуров. Цвет контура 
зависит от номера слоя. Соответствие задается через диалог выбора па-
литры, представленный на Рис. 2. Всего возможно задание 16-ти различ-
ных цветов, которые будут кодировать первые 16 слоев и периодически 
повторяться во всех последующих слоях. 

 
Рис. 2 Определение палитры кодирования слоёв в диалоге 

Layers Coding Palette 
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Включить режим показа контуров можно командой меню View->Redraw-

>Contour или комбинацией клавиш Alt+C или нажатием кнопки  на 
панели Инструментов. 

Режим показа дозы 

В режиме показа дозы элементы в видимых слоях отображаются в виде 
разноцветных закрашенных областей. Каждый цвет закраски кодирует 
определенный дозовый интервал. При включении данного режима допол-
нительно открывается панель с цветной шкалой, разделенная на 16 таких 
интервалов. Диапазон отображаемых доз задается в полях Min Level [%] 
и Max Level [%] на закладке Editor диалога View Options (чтобы от-
крыть диалог View Options выберите команду меню Options->View…). А 
цветовое соответствие задается в диалоге выбора палитры Dose Coding 
Palette. Чтобы открыть данный диалог, в закладке Editor нажмите кнопку 
Dose Palette.... Диалог Dose Coding Palette подобен тому, что изобра-
жен на Рис. 2 для цветового кодирования слоев. Всего возможно задание 
16-ти различных цветов, которые будут кодировать 16 дозовых интерва-
лов внутри заданного диапазона. Если доза элемента лежит за пределами 
нижней или верхней границ заданного диапазона, данный элемент будет 
отображаться в цветах самого нижнего или самого верхнего интервала, 
соответственно. 

Изначально, для дозовых интервалов установлена контрастная палитра 
(Contrast Palette), которую можно переопределить по своему усмотрению. 

Включить режим показа дозы можно командой меню View->Redraw-

>Dose или комбинацией клавиш Alt+D или нажатием кнопки  на па-
нели инструментов. 

Режим показа 3D атрибута 

В режиме показа 3D атрибута элементы в видимых слоях отображаются в 
виде разноцветных закрашенных областей. Каждый цвет закраски коди-
рует определенный интервал величин 3D атрибута. При включении данно-
го режима открывается также панель с цветной шкалой, разделенная на 
16 таких интервалов. Соответствие 3D атрибута и цвета задается через 
диалог выбора палитры, где задаются диапазон отображаемых величин 3D 
атрибута и выбирается соответствующий им цвет. 

Включить режим показа 3D атрибута можно командой меню View-
>Redraw->3D Attribute или комбинацией клавиш Alt+3. 

Показ слоев (активные слои) 

Существуют и другие опций отображения элементов структуры в окне ре-
дактора, например, запрет показа элементов лежащих в каком-либо из 
слоев. По умолчанию, изначально для каждой структуры устанавливается 
режим показа всех имеющихся в ней слоев. Для того чтобы отменить по-
каз каких-либо из имеющихся слоев, выберите команду меню View-
>Redraw->Layers… или нажмите комбинацию клавиш Alt+Y. Затем, в 
открывшемся диалоге Active Layers оставьте селектированными только 
те слои, которые должны остаться видимыми, и нажмите кнопку OK. 

Большинство редакторских операций (удаление, трансформация, группи-
ровка, разгруппировка и др.), а также экспонирование выполняются толь-
ко для элементов в видимых (активных) слоях, даже если эти элементы 
были селектированы до того как оказались в неотображаемых слоях. 

Уровни иерархии 
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При показе иерархических структур в окне редактора, по умолчанию показы-
вается самый верхний (0-ой) уровень иерархии. Нажимайте клавиши 1, 2, 3 
или 4 для показа следующих уровней иерархии – первого, второго, третьего 
или до самого нижнего уровня, соответственно. Переключение показываемых 
уровней иерархии можно выполнять также командами меню View-
>Hierarchy. 

 

Дизайн структуры 

Создание новой структуры 

Как было сказано выше, при открытии нового файла, создается только одна 
структура с именем MAIN. Для добавления новых структур в файл откройте 
диалог Edit Structure (Edit->Structure…) и нажмите в нем кнопку New  (см. 
Рис 3). В открывшемся диалоге New Structure введите имя новой структуры, 
которое должно быть уникальным, в рамках данного файла. Нажмите на 
кнопку OK чтобы закрыть диалог New Structure. Новая структура будет соз-
дана при закрытии диалога и ее имя будет добавлено в список в диалоге Edit 
Structure. Подобным же образом может быть добавлено любое необходимое 
количество новых структур. Чтобы открыть вновь созданную структуру в окне 
редактора, выберите ее в списке и нажмите кнопку Edit. 

  
Рис. 3 Создание новой структуры в диалоге New Structure 

Новая структура может быть создана на основе дизайна уже существующей 
структуры. Например, если необходимо какую-то часть элементов перемес-
тить или скопировать в отдельную структуру, выделите эти элементы и выбе-



Руководство Пользователя Редактор литографических структур 
 

www.nanomaker.com  11 

рите команду меню Edit->Group…. В результате этих действий откроется 
диалог Group to Structure. Задайте имя для новой структуры и отметьте га-
лочкой чекбокс Delete Elements, если вы хотите чтобы в результате опера-
ции селектированные элементы оказались только в новой структуре. Отметь-
те галочкой In New Editor Window, если вы хотите, чтобы после закрытия 
диалога открылось окно редактора со вновь созданной структурой. 

Удаление структуры 
Для удаления структуры из файла, откройте диалог Edit Structure (Edit-
>Structure…), селектируйте структуру в списке и нажмите кнопку Delete. В 
результате этой операции структура и все входящие в нее ее элементы будут 
удалены безвозвратно. 

Изменение атрибутов существующей структуры 

Для того чтобы переименовать существующую структуру откройте диалог Edit 
Structure (Edit->Structure…), выберите структуру в списке и нажмите 
кнопку Modify. В открывшемся диалоге Modify Structure измените имя 
структуры. Новое имя также должно соответствовать требованиям наимено-
вания структур, которые были описаны выше в разделе Структуры (Struc-
tures). 

Кроме того, диалог Modify Structure позволяет изменить шаг сетки разреза-
ния. 

Если разрезание не было еще задано, отметьте чекбокс Allow Divide by Grid 
и задайте требуемый шаг сетки в поле Grid Size [um]. 

Если необходимо отменить разрезание по сетке, снимите отметку с чекбокса 
Allow Divide by Grid. 

Далее, диалог позволяет определить сдвиг начала координат структуры отно-
сительно центра поля экспонирования (Scan Field). Начало координат струк-
туры  - это точка с координатами 0,0 в дизайне. 

Зачастую структуры проектируются несимметричными относительно центра 
координат. Поэтому, иногда при экспонировании структура может не поме-
щаться в границах поля, притом, что собственные габаритные размеры струк-
туры не будут превышать габариты поля экспонирования. Это происходит по-
тому, что начало координат дизайна совмещается с центром поля экспониро-
вания по умолчанию. Чтобы устранить эту проблему задайте смещение нача-
ла координат в полях Origin X [um] и Origin Y [um]. 

Параметры XY Range [mm] дают справку о максимальных возможных габа-
ритах структуры при данном разрешении файла структуры. Подробнее о мак-
симальных возможных габаритах было сказано выше в разделе Разрешение 
(Resolution). 

Нажмите кнопку OK для того чтобы закрыть диалог и произвести изменения. 

Сводная информация о структуре 
Для показа сводной информации о структуре выберите команду меню View-
>Summary… или нажмите комбинацию клавиш Alt+=. В диалоге Summary 
of "<наименование>" Structure выводится информация о габаритах струк-
туры, общем количестве элементов, количестве среди них вставок структур и 
селектированных элементов. Далее следует информация о таких атрибутах 
как, разрешение, шаг сетки разрезания и наличие 3D признака. И ниже ин-
формация о существующих слоях. 
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Рис. 4  Диалог сводной информации о структуре 

Установка текущих значений атрибутов для новых элементов 

Итак, для того чтобы начать проектирование новой структуры или отредакти-
ровать уже существующий дизайн, нужно открыть окно редактора содержа-
щее данную структуру. Как это сделать написано в предыдущем разделе. 

Перед началом ввода новых элементов откройте диалог Attributes (командой 
Insert->Attributes… или нажатием на клавишу A) для того чтобы установить 
значения нескольких параметров, которые будут использованы в атрибутах 
новых элементов. 

 
Рис.5  Установка исходных значений атрибутов в диалоге Attributes 

В исходных установках диалога: 

• доза (Dose) эквивалентна 100%; 

• слой (Layer) задан 0; 

• ширина (Width) точек и полилиний эквивалентна 0 мкм; 

• высота (Height) и ширина (Width) символов вводимого текста эквива-
лентна 8 мкм и 5 мкм, соответственно; 

• количество сегментов для аппроксимации дуги в π/2 градусов при вводе 
колец и окружностей (Segments) эквивалентно 8. 

Если необходимо, измените эти параметры и закройте диалог нажатием на 
кнопку OK. Теперь, каждый вновь создаваемый вами элемент структуры бу-
дет иметь значения атрибутов в соответствии с величинами, установленными 
в этом диалоге. Если после ввода некоторого количества элементов, необхо-
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димо изменить какой-либо из параметров для ввода последующих элементов, 
откройте вновь диалог Attributes и измените его величину. 

Создание новых элементов 

Существует несколько способов ввода базовых элементов c помощью 
клавиатуры и мыши. Рассмотрим пример ввода прямоугольного элемента. 
Для входа в режим вставки можно использовать команду меню Insert-
>Rectangle или просто нажатие на клавишу R (или кнопку на панели Инст-

рументов ). Свидетельством перехода в данный режим будет появление 

курсора соответствующего вида  и захват указателя мыши внутри окна. 
Далее можно использовать такие приемы: 

Графический ввод с помощью мыши 

Передвиньте указатель мыши к точке первой вершины вводимого вами 
элемента.  Для точного попадания в необходимые вам координаты, повер-
ните колесо мыши, чтобы увеличить масштаб до достаточной точности. 
Нажмите левую кнопку мыши, чтобы ввести первую вершину. Если необ-
ходимо, уменьшите масштаб и переместите указатель мыши к точке сле-
дующей (противоположной в случае прямоугольника) вершины. Если это 
необходимо для точного попадания в необходимые вам координаты, вновь 
увеличьте масштаб. Нажмите левую кнопку мыши, чтобы завершить ввод 
элемента. До тех пор, пока ввод не завершен, отменить предыдущую вве-
денную вершину можно нажатием на правую кнопку мыши. 

Графический ввод с клавиатуры 

Передвиньте указатель мыши к точке первой вершины и оставьте мышь в 
покое. Далее, используя клавиши-стрелки, установите курсор в необхо-
димые вам координаты. При этом, для точного попадания в необходимую 
точку, используйте комбинированно клавишу Shift, для прыжка курсора в 
точно в узел координатной сетки, клавиши - и +  для изменения шага 
курсора, клавиши / и * для изменения масштаба. Когда курсор окажется 
в правильной позиции, нажмите клавишу Space для ввода вершины. В 
случае ошибки, с помощью клавиши Backspace ввод вершины можно от-
менить. Используя клавиши-стрелки (или мышь) переместите курсор к 
следующей (противоположной) вершине. Если необходимо, вновь исполь-
зуйте клавиши - и + для изменения шага курсора, клавиши / и * для из-
менения масштаба. Когда курсор окажется в правильной позиции, нажми-
те клавишу Space для ввода вершины и завершения ввода прямоугольно-
го элемента. 

Ввод с клавиатуры в цифровом виде 

Нажмите клавишу X, для того чтобы установить фокус ввода с клавиатуры 
в поле показа (и ввода) текущих координат курсора, лежащее на нижнем 
обрамлении фрейма программы. Введите в числовом виде X-координату 
первой вершины элемента. Нажмите клавишу Tab чтобы переместить фо-
кус ввода в поле показа Y-координаты и введите в это поле в числовом 
виде Y-координату вершины. Нажмите клавишу Enter чтобы вернуть фо-
кус в окно редактора. Нажмите клавишу Space для ввода вершины эле-
мента. Снова нажмите клавишу X, для того чтобы установить фокус ввода 
с клавиатуры в поле показа текущих координат курсора и повторите снова 
все описанные выше действия для ввода следующей вершины элемента. 

Любые из приведенных способов можно комбинировать произвольным об-
разом исходя из индивидуальных предпочтений. 

Для удобства ввода нескольких однотипных элементов, до начала ввода 
установите режим множественного ввода. Сделать это можно выбором ко-
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манды Insert->Multiple Mode (либо нажатием клавиши H или нажатием 

самой нижней кнопки  на панели Инструментов в правом ряду). Если 
установлен данный режим, тогда можно вводить однотипные элементы, 
например прямоугольники, последовательно, один за другим, выбрав ввод 
такого элемента только единожды перед началом первого ввода. Для вы-
хода из режима множественного ввода нажмите клавишу Esc. 

В общем случае, при вводе элементов различных типов с произвольным 
количеством вершин, ввод вершины обычно выполняется нажатием на 
клавишу Space или левую кнопку мыши. Завершение ввода элемента про-
изводится нажатием на кнопку Enter или двойным щелчком на левую 
кнопку мыши. Отмена только что введенной вершины выполняется нажа-
тием на клавишу Backspace или правую кнопку мыши. Выход из режима 
ввода производится нажатием на клавишу Esc или двойным кликом на 
правую кнопку мыши. 

Цифровой ввод с помощью диалога 

Существует также возможность ввода базовых элементов в цифровом виде 
используя поля ввода в диалоге. Для ввода, например прямоугольника, 
выберите команду меню Insert->Numerically->Rectangle. В открывшем-
ся диалоге выберите первую строчку в окне Element's Nodes [um], ко-
торая содержит координаты одной из вершин прямоугольника (условно 
она названа как левая нижняя вершина). Сделайте строку доступной для 
редактирования, нажатием на клавишу Space (или кликом левой кнопки 
мыши, или выбором команды Edit в контекстном меню, всплывающем по-
сле клика на строке правой кнопки мыши). Введите необходимые вам ко-
ординаты вершины вместо имевшихся чисел в строке. Обязательно ос-
тавьте разделяющий координаты X и Y пробел. Перейдите ко второй стро-
ке в окне и отредактируйте координаты противоположной вершины (см. 
Рис. 6). Нажмите кнопку Apply для ввода элемента без выхода из диалога 
и продолжите ввод следующего прямоугольника подобным образом. 

 
Рис.6  Ввод прямоугольника с помощью диалога Insert Rectangle Numerically 

Подобным образом могут вводиться точки (Points), полилинии (Polyline), 
прямоугольники (Rectangle), контуры (Contour), окружности (Circle) и 
кольца (Ring). 

При вводе окружности или кольца первая вводимая позиция или величина 
определяют положение центра, а последующие радиус(ы) окружно-
сти(ей). 

Создание других, более сложных типов элементов будет описано позднее. 
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Селектирование (выделение) элементов 

Любые операции в редакторе по преобразованию элементов, связанные с 
преобразованиями формы или атрибутов, а также удаление и размножение 
выполняются только для селектированных элементов. Количество выделен-
ных элементов в структуре можно видеть в крайнем правом поле, лежащем на 
нижнем обрамлении окна программы. 

Для того чтобы селектировать все элементы в структуре, нажмите комбина-
цию клавиш Alt+A или выберите команду меню Edit->Select->All. 

Для того чтобы селектировать только нужные элементы, воспользуйтесь од-
ной из команд в меню Edit->Select: 

• In – позволяет селектировать элементы, находящиеся полностью внут-
ри  произвольно очерченной прямоугольной области 

• At – позволяет селектировать элемент, внутрь границ которого помещен 
курсор 

• Layer…– позволяет селектировать элементы, лежащие в выбранных 
слоях 

• Reference…– позволяет селектировать элементы, являющиеся ссылка-
ми на выбранные в списке структуры. 

Для того чтобы отменить селектирование всех элементов в структуре, нажми-
те комбинацию клавиш Shift+Alt+A. 

Для того чтобы отменить селектирование только нужных элементов, восполь-
зуйтесь одной из команд в меню Edit->Unselect: 

• In – позволяет отменить селектирование элементов, находящихся пол-
ностью внутри  произвольно очерченной прямоугольной области 

• At – позволяет отменить селектирование элемента, внутрь границ кото-
рого помещен курсор 

• Layer… – позволяет отменить селектирование элементов, лежащих в 
выбранных слоях 

• Reference… – позволяет отменить селектирование элементов, являю-
щихся ссылками на выбранные в списке структуры. 

Кроме рассмотренных выше вариантов, можно воспользоваться режимами се-
лектирования/деселектирования с помощью указателя мыши. Чтобы перевес-
ти курсор в режим селектирования, выберите команду меню Edit->Select 

Mode или нажмите комбинацию клавиш Alt+M (или нажмите кнопку  на 
панели Инструментов). В этом режиме: 

• Двойной клик левой кнопки мыши в окне редактора позволяет селекти-
ровать все элементы структуры. 

• Одиночный клик левой кнопки мыши над элементом позволяет селекти-
ровать только данный элемент. 

• Нарисованный с помощью прижатой левой клавиши мыши штриховой 
прямоугольный контур отмечает все элементы, помещающиеся внутрь 
данного прямоугольника. 

• Клик правой кнопки мыши обращает режим селектирования в режим 
отмены селектирования. Теперь: 

 Двойной клик левой кнопки мыши в окне редактора позволяет де-
селектировать все элементы структуры. 

 Одиночный клик левой кнопки мыши над элементом позволяет де-
селектировать только данный элемент. 
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 Нарисованный с помощью прижатой левой клавиши мыши штри-
ховой прямоугольный контур позволяет деселектировать все эле-
менты помещающиеся внутрь данного контура. 

• Каждый новый клик правой кнопки мыши инвертирует режим селекти-
рования. Текущий режим селектирования/деселектирования легко уста-
навливается по типу курсора. В режиме селектирования в курсоре при-

сутствует плюс . При деселектировании в курсоре присутствует ми-

нус . 

Выход из режима селектирования производится нажатием на клавишу Esc или 
двойным кликом на правую кнопку мыши. 

Удаление 
Для удаления сначала селектируйте элемент(ы), затем нажмите клавишу 

Delete (или выберите команду меню Edit->Clear или кнопку  на Инсту-
ментальной панели). 

Удаление с возможностью вставки 

Для удаления элемента(ов) с возможностью последующей вставки (через бу-
фер копирования), сначала селектируйте элемент(ы), а затем нажмите ком-
бинацию клавиш Shift+Delete (или выберите команду меню Edit->Cut или 

кнопку  на Инстументальной панели). 

Копирование 

Для того чтобы копировать (поместить в буфер копирования) один или не-
сколько элементов структуры, селектируйте их вначале. Затем выберите ко-
манду меню Edit->Copy или нажмите комбинацию клавиш Ctrl+Insert (или 

кнопку  на панели Инструментов). 

Вставка 
Для того, чтобы вставить в структуру элемент(ы), ранее помещенный(е) в 
буфер копирования (clipboard) процедурами копирования или удаления, вы-
берите команду меню Edit->Paste или нажмите комбинацию клавиш 

Shift+Insert (или кнопку  на панели Инструментов). Сразу после этого 
включается режим вставки: указатель мыши захватывается в окне, появляет-
ся специальный курсор, контур(ы) вставляемого(ых) элемента(ов) рисуется 
штриховыми линиями в поле структуры. Геометрический центр контура(ов) 
отмечается штриховым перекрестьем. При нахождении указателя мыши над 
образом элемента(ов), внутри воображаемой прямоугольной области, описы-

вающей его вершины, курсор имеет форму указателя с перекрестьем . 
Если же указатель мыши находится вне воображаемой прямоугольной облас-

ти, курсор имеет форму указателя с незамкнутой окружностью , символи-
зирующей операцию поворота. 

Для того чтобы передвинуть контуры в нужное место структуры, поместите 
курсор внутрь воображаемой прямоугольной области, захватите образ нажа-
тием на левую кнопку мыши и, удерживая ее в таком состоянии, переместите 
в нужное место и затем отпустите кнопку. 

Если необходимо развернуть вставляемый(е) элемент(ы), поместите курсор 
вне воображаемой прямоугольной области, захватите образ нажатием на ле-
вую кнопку мыши и, удерживая ее в таком состоянии, перемещайте курсор по 
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дуге большой окружности, описывающей образ, до тех пор, пока контур(ы) 
не примут желаемое положение и затем отпустите кнопку. 

Если до нажатия на левую кнопку мыши указатель находится вблизи геомет-
рического центра образа на расстоянии меньшем половины шага курсора, то 
при нажатии на нее (кнопку мыши) указатель прыгнет в положение геомет-
рического центра. И, таким образом, при дальнейшем перемещении образа 
будет проще контролировать его положение. Для большего удобства и точно-
сти используйте клавиши-стрелки для перемещения образа с шагом курсора. 
Если необходимо, используйте клавиши - и + для изменения шага курсора, а 
также клавиши / и * (колесо мыши) для изменения масштаба. 

Для вставки элемента(ов) в нужном месте нажмите клавишу Enter или дваж-
ды кликните левую кнопку мыши. 

Для отмены вставки нажмите клавишу Esc или дважды кликните правую 
кнопку мыши. 

Кстати, вставлять элементы можно, как в данную структуру, где они были 
скопированы, так и в любую другую в данном файле, а также и в другую ли-
тографическую структуру. 

 

Отмена Удаления / Вставки 

Для отмены последних операций по удалению / вставке элементов восполь-
зуйтесь командами меню Edit->Undo (либо комбинацией клавиш Ctrl+Z) или 
Edit->Redo (либо комбинацией клавиш Ctrl+Shift+Z). 

 

Создание других элементов 
Text 

Для того чтобы добавить надписи в дизайн структуры удобно использовать 
элемент Text. 

Используя поле редактирования в диалоге Insert Text, который вызывается 
командой меню Insert->Text… или просто нажатием на клавишу T (или на 

кнопку  на панели Инструментов), можно набрать нужный текст и долж-
ным образом его сформатировать. В тексте можно использовать прописные и 
строчные буквы латинского или кириллического алфавита, цифры и другие 
символы клавиатуры. После закрытия диалога клавишей OK, включается ре-
жим вставки: указатель мыши захватывается в окне, появляется соответст-

вующий курсор , к которому прицеплен образ вводимого текст. Перемес-
тите курсор в нужное место структуры и расположите текст нужным образом. 
Используйте клавиши / и * (или колесо мыши) для изменения масштаба окна 
редактора, комбинацию клавиш Shift+/ и Shift+* для изменения размера 
символов в тексте, комбинацию клавиш Shift+R для поворота образа с шагом 
15 градусов. 

Для ввода элемента нажмите клавишу Return или левую клавишу мыши. При 
вводе Text преобразуется в набор независимых контуров и как единый эле-
мент более не существует. 

Time&Date 

Специальный элемент, который встраивается в дизайн структуры для того, 
чтобы зафиксировать дату и время экспонирования. 
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Для того чтобы вставить элемент выберите команду меню Insert-

>Time&Date (или нажмите кнопку  на панели Инструментов). Далее, в 
режиме вставки используйте действия и команды, описанные выше для эле-
мента Text, чтобы расположить элемент Time&Date нужным образом, с нуж-
ными размерами в нужном месте структуры. 

В отличие от элемента Text, при вставке, элемент Time&Date не трансформи-
руется в набор контуров, а существует как единый элемент с некоторыми 
специфическими свойствами. Так, габаритные размеры элемента определяют-
ся примерно, зависят от формата представления даты и времени и постоянно 
колеблются в небольших пределах в соответствии с текущим временем. Необ-
ходимо это учитывать при вставке данного элемента в дизайн структуры. Да-
лее, при выборе дозы для элемента Time&Date, необходимо учитывать, что 
процедура коррекции эффекта близости не корректирует его дозу и не учи-
тывает его присутствие вблизи корректируемых элементов. 

Для того чтобы изменить формат представления даты и времени, а также до-
бавить комментарии – селектируйте только данный элемент и используйте 
команду меню Edit->Modification…. Подробное описание форматов пред-
ставления и примеры можно найти в Help по данной теме. 

Дополнительными атрибутами элемента Time&Date являются строка формата 
представления даты и времени, а также матрица преобразования координат. 

Comments 

Данный элемент также как и Text может использоваться для добавления над-
писей и комментариев в дизайн структуры. Для того чтобы вставить элемент 
выберите команду меню Insert->Comments и в открывшемся диалоге набе-
рите текст комментария. Длина строки ограничена 255 символами. Нажмите 
кнопку OK и, далее, в режиме вставки используйте действия и команды, опи-
санные выше для элемента Text, чтобы расположить элемент Comments нуж-
ным образом, с нужными размерами в нужном месте структуры. 

В отличии от элемента Text, надпись в котором можно сформатировать в не-
сколько строк, текст в Comments существует в виде одной строки. Как и эле-
мент Time&Date, Comments не трансформируется в набор контуров при 
вставке, а существует как единый элемент со специфическими свойствами. В 
частности, текст комментария может быть полностью подменен специальной 
командой при экспонировании в командном режиме (Batch Processing). Дета-
ли смотрите в Help по командному режиму. Замена текста может привести к 
изменению габаритов элемента. Этот факт необходимо учитывать при вставке 
данного элемента в дизайн структуры. Далее, при выборе дозы для элемента 
Comments, подобно Time&Date, необходимо учитывать, что процедура кор-
рекции эффекта близости не корректирует его дозу и не учитывает его при-
сутствие вблизи корректируемых элементов. 

Для того чтобы изменить текст комментария на этапе дизайна – селектируйте 
только данный элемент и используйте команду меню Edit->Modification…. 

Дополнительными атрибутами элемента Comments являются строка коммен-
тария, а также матрица преобразования координат. 

Structure reference 

Для оптимизации дизайна структуры и уменьшения размеров файла данных 
повторяющиеся элементы могут быть вынесены в отдельную новую структуру 
в данном файле с помощью диалога Group To Structure (Edit->Group…), 
ссылка на которую затем может быть вставлена в исходную структуру в нуж-
ное место. Таким образом, исходная структура становится иерархической, 
включающей в себя ссылку на другую структуру из данного файла. Подобные 
ссылки на вставляемую структуру (элементы Structure reference) могут быть 
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добавлены сколь угодно много раз в произвольные места исходной структу-
ры. При вставке каждая ссылочная структура может быть повторена много-
кратно с заданным шагом в горизонтальном и вертикальном направлениях 
(Array of Structure references), повернута на произвольный угол, увеличена 
или уменьшена. В свою очередь, любая из вставляемых структур может 
включать ссылки на другие структуры из данного GDB файла, образуя сле-
дующий уровень иерархии и т.д. Не допускается только рекурсивное зацик-
ливание ссылок на структуры, но за этим следит сама программа и не разре-
шит выполнить такую вставку. 

Для того чтобы вставить элемент Structure reference выберите команду меню 
Insert->Structure… и в открывшемся диалоге выберите вставляемую струк-
туру из списка Structure Name (см. Рис 7). Определите точку вставки как 
сдвиг начала координат вставляемой структуры в полях Inserting Point. За-
дайте, если необходимо, углы поворота в полях Rotate, коэффициенты мас-
штабирования в полях Magnification, количество повторов и шаги в полях 
Repeat, коэффициент изменения дозы элементов вставляемой структуры в 
поле Dose Factor и нажмите клавишу OK. 

 
Рис.7  Создание элемента Structure reference посредством диалога Insert Structure 

Элемент Structure reference (вставка структуры) изображается прямоугольной 
областью ограниченной утолщенным контуром голубого цвета. Границы об-
ласти описывают выступающие вершины элементов вставляемой структуры. 

 
Рис.8  Массив вставок структуры line_50nm_20um в структуру MAIN 
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По центру Structure reference красным цветом обозначается имя вставляемой 
структуры. Если структура вставляется с повторами (массив вставок структу-
ры/array of structure references), тогда в надпись, вслед за именем структуры, 
в квадратных скобках добавляются количества повторов в горизонтальном и 
вертикальном направлениях, как это представлено на Рис. 8. 

В качестве вставляемой структуры может выступать целый файл одного из 
поддерживаемых форматов GDB, ELM, GDS, DXF. Для того чтобы вставить 
другой файл как Structure reference в текущий файл выберите команду меню 
Insert->File… и в открывшемся диалоге Open найдите и кликните нужный 
файл для того чтобы его загрузить. Все структуры выбранного файла будут 
скопированы в текущий файл. Бывшая структура MAIN из выбранного файла 
в текущем файле будет носить имя своего бывшего файла. Если в выбранном 
файле нет структуры MAIN, тогда в текущий файл будет добавлена пустая 
структура с именем выбранного файла. Новый Structure reference элемент бу-
дет ссылаться на структуру названную именем вставленного файла. 

Для показа элементов вставляемой структуры в первом уровне иерархии на-
жмите клавишу 1. 

Элемент Structure reference не имеет атрибутов Доза (Dose), 3D атрибут (3D 
Attribute), Слой (Layer) и всегда перечисляется в 0 слое. Его атрибутами яв-
ляются точка вставки, углы поворота, коэффициенты масштабирования, ко-
личество и шаги повторов, коэффициент изменения дозы. 

Для того чтобы изменить атрибуты Structure reference – селектируйте только 
данный элемент и используйте команду меню Edit->Modification… для от-
крытия диалога Modification of Structure Reference. 

Специальным случаем вставки структуры является вставка файла (File 
Insertion) одного из поддерживаемых форматов – GDB, ELM, GDS, DXF. При 
такой вставке вставляемый файл целиком копируется в данный GDB файл и 
дальнейшее его отдельное существование уже не является необходимым ус-
ловием. Вставка файла изображается подобно вставке структуры прямо-
угольной областью ограниченной утолщенным контуром голубого цвета. Гра-
ницы области описывают выступающие вершины элементов вставляемой 
структуры. По центру Structure reference красным цветом обозначается имя 
вставляемой структуры. 

При этом основновной вставляемой структурой является MAIN 

Dose map 

NanoMaker позволяет проектировать литографические структуры на основе 
информации заключенной в растровых изображениях. Для выполнения этой 
задачи служит элемент Dose map. При добавлении такого элемента в исход-
ную структуру, на основе параметров изображения и одной из базовых струк-
тур (ею может быть единичный круг, либо единичный квадрат, либо политоч-
ка) образуется массив вставок базовой структуры (Array of Structure refer-
ences), в котором число рядов и столбцов равно ширине и высоте изображе-
ния в пикселях, соответственно. Таким образом, каждому пикселю изображе-
ния соответствует одна из вставок базовой структуры. Интенсивность пикселя 
(R+G+B)/3 используется как коэффициент умножения в % при определении 
результирующей дозы для элементов вставки базовой структуры. По умолча-
нию, шаги вставок структуры выбираются равными габаритам структуры, так 
чтобы вставки прилегали плотно друг к другу как пиксели в исходном изо-
бражении. При желании, шаги могут быть изменены. Кроме того, массив мо-
жет быть смаштабирован и повернут. GDB файл, содержащий элементы Dose 
map должен переноситься совместно с изображениями, на основе которых 
образованы данные специальные элементы. 

Создать элемент Dose map можно одним из двух способов: 
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• импортировать изображение командой File->Import->(по шаблону 
TIFF Image Files (*.TIF) или Bitmap Image Files (*.BMP); 

• воспользоваться командой Insert->Structure with Dose Map… и вста-
вить в данную структуру массив вставок какой либо из структур из дан-
ного файла на основе информации из присоединенного изображения. 

На Рис. 9 представлен диалог, который открывается при импорте данных об 
изображении из выбраного файла. В данном случае выбран файл 
splnano_15.bmp, который будет являться основой создаваемого Dose map 
элемента. В качестве заполняющей структуры выбрана CIRCLE_(D_1μm), ко-
торая представляет собою кружок диаметром 1 μm. 

 
Рис. 9  Создание элемента Dose map на основе файла изображения splnano_15.bmp 

и структуры CIRCLE_(D_1μm). 

Для показа элементов вставляемой структуры в первом уровне иерархии на-
жмите клавишу 1. Для показа доз нажмите комбинацию клавиш Alt+D. 

Результирующая структура после вставки Dose map элемента, на первом 
уровне иерархии в режиме показа дозы изображена на Рис. 10. 

Элемент Dose map имеет те же атрибуты, что и Structure reference и, допол-
нительно, хранит путь к файлу связанного (присоединенного) изображения. 

Для того чтобы изменить атрибуты Dose map – селектируйте только данный 
элемент и используйте команду меню Edit->Modification…. 

Элемент Dose map изображается практически таким же образом, как и массив 
вставок структур (Array of Structure references). Дополнительно, по центру 
Dose map, ниже имени вставляемой структуры, также красным цветом, но 
меньшим шрифтом дописывается слово DoseMap и путь к присоединенному 
файлу изображения. 
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Рис. 10  Результирующая структура после вставки Dose map элемента, на первом уровне иерар-

хии в режиме показа дозы 

Reference map 

Для проектирования и изготовления радужных голограмм был разработан 
специальный элемент, который представляет собою матрицу вставок имено-
ванных структур, которая организуется на основе информации хранимой в 
связанном изображении. Этот элемент и есть Reference map. 

Связанное изображение хранится в отдельном файле BMP или TIFF формата и 
имеет глубину 8 бит/пиксель. Размер изображения (это количество пикселей 
по оси X и по оси Y) определяет размер матрицы вставок (и самой голограм-
мы). Уровень серого каждого из пикселей изображения (это число от 0 до 
255) является ключом для подстановки соответствующей структуры в каждом 
из узлов матрицы. Это становится возможным, потому что в Reference map 
все ссылочные структуры именуются в соответствии с определенным прави-
лом. Их имена состоят из необязательного префикса и номера. Префикс явля-
ется одинаковым для всех структур и может содержать произвольное количе-
ство символов латинской клавиатуры. Номер состоит из трех цифр, от 000 до 
255. Например, если в качестве префикса выбрана строка "Toy-", тогда имена 
ссылочных структур в файле будут выглядеть следующим образом: "Toy-000", 
"Toy-021", "Toy-205" и так далее. Таким образом, каждая Reference map мо-
жет ссылаться на 256 различных именованных структур. 

Дизайн реальной голограммы может содержать десятки Reference map эле-
ментов для создания различных цветовых, динамических и других эффектов. 

Создать элемент Reference map можно одним из двух способов: 

• импортировать дизайн радужной голограммы, подготовленный програм-
мой "RainBow", командой File->Import->(по шаблону Elements Files 
(*.ELM); 

• воспользоваться командой Insert->Structure with Reference Map… и 
вставить в данную структуру матрицу вставок структур из данного фай-
ла. Т.е. вставляемые структуры уже должны существовать в файле на 
момент создания Reference map. Так же необходимо придерживаться со-
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глашения о наименовании структур. Если необходимые для вставки 
структуры отсутствуют в файле, Reference map окажется пустой. 

Чтобы проверить результат создания элемента, откройте для показа первый 
уровень иерархии, нажав на клавишу 1. 

Элемент Reference map изображается практически таким же образом, как и 
массив вставок структур (Array of Structure references) – голубой прямоуголь-
ник ограничивает пространство вставляемых структур; по центру надпись 
красным цветом состоящая из имени вставляемых структур (префикс за кото-
рым следует набор символов <xxx> символизирующий изменяющийся номер 
от 000 до 255), а затем, в квадратных скобках добавляются количества по-
второв в горизонтальном и вертикальном направлениях. Дополнительно, по 
центру Reference map, ниже имени вставляемых структур, также красным 
цветом, но меньшим шрифтом дописывается слово RefMap и далее путь к при-
соединенному файлу изображения. 

Для показа элементов вставляемых структуры в первом уровне иерархии на-
жмите клавишу 1. Для показа доз нажмите комбинацию клавиш Alt+D. 

Элемент Reference map имеет те же атрибуты, что и Structure reference и, до-
полнительно, хранит путь к присоединенному файлу изображения и строку 
префикса. Для того чтобы изменить атрибуты Reference map – селектируйте 
только один элемент и используйте команду меню Edit->Modification…. 

Преобразования элементов 

В зависимости от стоящих задач редактирования структуры и от типа редак-
тируемого элемента существует несколько способов их преобразования. 

1. Изменение атрибутов 

Для того чтобы изменить дозу, слой (и 3D атрибут, в случае 3D структуры) 
элемента или группы элементов необходимо его(их) селектировать, и за-
тем открыть диалог Change Attributes командой меню Edit->Change 
Attributes… или нажатием горячей клавиши B. 

Поскольку диалог позволяет производить изменение нескольких атрибу-
тов одновременно, обратите внимание, чтобы селекторы всех операций 
изначально находились в состоянии NONE (см. Рис. 11). 

Если необходимо изменить дозу элемента(ов) - установите селектор опе-
раций с дозой в состояние SET и введите новое значение дозы в поле 
Dose [%]. 

 
Рис. 11  Изменение атрибутов элементов с помощью диалога Change Attributes 
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Если хотите уменьшить/увеличить дозу элемента(ов) в произвольное ко-
личество раз -установите селектор операций с дозой в состояние SCALE и 
введите коэффициент в поле Factor. 

Если хотите изменить номер слоя элемента(ов) - установите селектор опе-
раций со слоями в состояние SET и введите новое значение слоя в поле 
Layer Number. 

Если хотите изменить 3D атрибут элемента(ов) - установите селектор опе-
раций с 3D атрибутом в состояние SET и введите новое значение 3D атри-
бута в поле 3D Attribute. 

Если хотите уменьшить/увеличить величину 3D атрибута элемента(ов) в 
произвольное количество раз -установите селектор операций с 3D атрибу-
том в состояние SCALE и введите коэффициент в поле Factor. 

Нажмите кнопку OK для выполнения операции изменения атрибута(ов). 

Для изменения дополнительных атрибутов небазовых элементов 
(Time&Date, Comments, Structure reference, Dose map и Reference map) 
необходимо селектировать только один из этих элементов и затем открыть 
диалог модификации командой меню Edit->Modification… или нажатием 
клавиши M. Набор атрибутов доступных к изменению и содержание диа-
лога зависит от типа выбранного элемента: 

• для Time&Date и Comments элементов доступна для коррекции 
только строка представления информации. 

• для Structure reference, Dose map и Reference map доступны к пре-
образованию параметры матрицы трансформации, точка вставки, 
коэффициент изменения дозы, а также ссылочная(ые) структура(ы)  

• для Dose map и Reference map, кроме того, можно изменить свя-
занное изображение  

2. Изменение геометрии 

Деформация (Skew) 

Для изменения положения вершин базовых элементов (а также Time&Date 
и Comments), сначала селектируйте только один из этих элементов, а за-
тем выберите команду Edit->Transform->Skew или используйте комби-
нацию клавиш Ctrl+Shift+S. 

Маленькие коричневые прямоугольники отмечают активные области кон-
трольных точек в вершинах элемента, которые используются в процедуре 
преобразования. Для изменения положения вершины, захватите ее кон-
трольную точку, используя левую клавишу мыши, и перетащите в нужное 
место. Для точного позиционирования контрольной точки используйте со-
вместно мышь и клавиатуру. При нажатой и удерживаемой левой кнопке 
мыши используйте клавиши-стрелки, для перемещения контрольной точки 
на один шаг курсора. Используйте комбинацию с клавишей Shift для 
прыжка курсора точно в узел координатной сетки, клавиши - и + для из-
менения шага курсора, клавиши / и * для изменения масштаба. 

В ходе процедуры контрольные точки (вершины) могут быть добавлены 
и/или удалены, чтобы сформировать нужную конфигурацию элемента. 

Чтобы вставить новую контрольную точку щелкните правой кнопкой мыши 
по одной из существующих контрольных точек, а затем выберите команду 
Add Vertex из всплывающего меню. Новая контрольная точка будет 
вставлена посредине отрезка соединяющего выбранную точку и сосед-
нюю, в направлении против часовой стрелки. 
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Чтобы удалить существующую контрольную точку щелкните правой кноп-
кой мыши по ней и выберите команду Delete Vertex из всплывающего 
меню. 

Чтобы завершить процедуру преобразования дважды щелкните левой 
кнопкой мыши или нажмите клавишу Enter. Для отмены процедуры на-
жмите клавишу ESC. 

Численное Преобразование (Numeric…) 

Преобразование посредством ввода числовых значений параметров вы-
полняется для произвольного количества выделенных элементов. С помо-
щью данной процедуры элементы могут быть размножены многократно с 
заданным шагом в горизонтальном и вертикальном направлениях, сдвину-
ты, увеличены или уменьшены и повернуты на произвольный угол относи-
тельно заданной точки. Кроме того, при размножении элементов можно 
задать также и приращение дозы новых элементов одним из двух спосо-
бов: увеличением на заданную величину или последовательным умноже-
нием дозы на заданный коэффициент. 

Чтобы выполнить преобразование, селектируйте элементы, а затем выбо-
ром команды Edit->Transform->Numeric… или нажатием комбинации 
клавиш Ctrl+Shift+N откройте диалог Numeric Transformation (см. Рис 
12). 

 
Рис. 12. Преобразование элементов с помощью диалога Numeric Transformation 

Нажмите кнопку Clear для того чтобы установить параметры преобразо-
вания по умолчанию. 

Для того чтобы сдвинуть элемент(ты) задайте величину сдвига в полях 
Shift X и Shift Y. в микронах 

Определите опорную точку, относительно которой будет производиться 
разворот и масштабирование в полях Base Point. 

Задайте, если необходимо, углы поворота в полях Rotate, в градусах, ко-
эффициенты масштабирования в полях Magnification, количество повто-
ров и шаги в полях Repeat, коэффициент изменения или величину при-
ращения дозы элементов в полях группы Repeat Dose Operation. 
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Отметьте галочкой чек-бокс Save Old для того чтобы в дополнение к пре-
образованным элементам сохранить в структуре и исходные элементы. 

Отметьте галочкой Select Old для того чтобы оставить селектированными 
исходные элементы после завершения процедуры преобразования. 

Отметьте чек-бокс Select New для того чтобы селектировать переобразо-
ванные элементы по завершении процедуры преобразования. 

Нажмите клавишу OK для того чтобы закрыть диалог и выполнить преоб-
разование. 

Move&Rotate 

Чтобы передвинуть и/или повернуть элемент или группу элементов на 
произвольное расстояние или угол селектируйте элемент(ы) и выберите 
команду меню Edit->Transform->Move&Rotate или используйте комби-
нацию клавиш Ctrl+Shift+М. 

Сразу после этого включается режим трансформации: указатель мыши за-
хватывается в окне, появляется специальный курсор, в правом верхнем 
углу открывается информационная панель и поверх изменяемых элемен-
тов штриховыми линиями рисуются их образы. Геометрический центр кон-
туров (центр описанного прямоугольника) отмечается штриховым пере-
крестьем. При нахождении указателя мыши над образом элемента(ов), 
внутри воображаемой прямоугольной области, описывающей его верши-

ны, курсор имеет форму указателя с перекрестьем . Если же указа-
тель мыши находится вне воображаемой прямоугольной области, курсор 

имеет форму указателя с незамкнутой окружностью , символизирую-
щей операцию поворота. 

Для того чтобы передвинуть контуры в нужное место структуры, помести-
те курсор внутрь воображаемой прямоугольной области, захватите образ 
нажатием на левую кнопку мыши и, удерживая ее в таком состоянии, пе-
реместите в нужное место. 

Если необходимо развернуть трансформируемый(е) элемент(ы), поместите 
курсор вне воображаемой прямоугольной области, захватите образ нажа-
тием на левую кнопку мыши и, удерживая ее в таком состоянии, переме-
щайте курсор по дуге большой окружности, описывающей образ, до тех 
пор, пока контур(ы) не примут желаемое положение. 

Если до нажатия на левую кнопку мыши указатель находится вблизи гео-
метрического центра образа на расстоянии меньшем половины длины 
мерного отрезка (шага зеленой сетки), то при нажатии на нее (кнопку 
мыши) указатель прыгнет в положение геометрического центра. И, таким 
образом, при дальнейшем перемещении образа будет проще контролиро-
вать его положение. Для большего удобства и точности используйте кла-
виши-стрелки для перемещения образа с шагом курсора. Если необходи-
мо, используйте клавиши - и + для изменения шага курсора, а также кла-
виши / и * (или колесо мыши) для изменения масштаба. 

Для перемещения элемента(ов) в нужном месте нажмите клавишу Enter 
или дважды кликните левую кнопку мыши. 

Для выхода из режима трансформации нажмите клавишу Esc или дважды 
кликните правую кнопку мыши. 

Rotate 180º 

Для того чтобы развернуть элемент на 180 градусов относительно его гео-
метрического центра, селектируйте этот элемент и выберите команду ме-
ню Edit->Transform->Rotate 180º или используйте комбинацию клавиш 
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Ctrl+Shift+8. Если селектирована группа элементов, тогда поворот будет 
выполнен относительно их общего геометрического центра. 

Rotate 90º CW 

Для того чтобы развернуть элемент или группу элементов на 90 градусов 
по часовой стрелке относительно геометрического центра селектирован-
ных объектов выберите команду меню Edit->Transform->Rotate 90º CW 
или воспользуйтесь комбинацией клавиш Ctrl+Shift+9. 

Rotate 90º CCW 

Для того чтобы развернуть элемент или группу элементов на 90 градусов 
против часовой стрелки относительно геометрического центра селектиро-
ванных объектов выберите команду меню Edit->Transform->Rotate 90º 
CCW или воспользуйтесь комбинацией клавиш Ctrl+Shift+7. 

Flip Horizontal 

Для того чтобы перевернуть элемент или группу селектированных элемен-
тов относительно воображаемой вертикальной оси проходящей через гео-
метрический центр селектированного(ых) объекта(ов) выберите команду 
меню Edit->Transform->Flip Horizontal или воспользуйтесь комбинаци-
ей клавиш Ctrl+Shift+H. 

Flip Vertical 

Для того чтобы перевернуть элемент или группу селектированных элемен-
тов относительно воображаемой горизонтальной оси проходящей через 
геометрический центр селектированного(ых) объекта(ов) выберите ко-
манду меню Edit->Transform->Flip Vertical или воспользуйтесь комби-
нацией клавиш Ctrl+Shift+V. 

 

3. Преобразование атрибутов и геометрии элементов 

Преобразование по формуле 

Размеры, пространственное положение и атрибуты селектированных эле-
ментов могут быть одновременно изменены посредством ввода соответст-
вующих математических выражений в диалоге Transform By Formula. 

Для того чтобы осуществить данное преобразование, селектируйте эле-
менты и откройте диалог командой меню Edit->Transform->By 
Formula… или нажатием комбинации клавиш Ctrl+Shift+F. Далее, в окно 
диалога нужно ввести одно или несколько математических выражений 
(формул), которые описывают операции преобразования атрибутов и/или 
геометрических параметров всех селектированных элементов в соответст-
вии с определенными правилами. Правила эти следующие: 

• Все выражения в основном являются операциями присвоения пере-
менной слева от знака равенства результата вычислений выполняе-
мых в правой части выражения. Например, выражения могут выгля-
деть как: 

coef=100;  d=coef*log(d); 

• В первом выражении объявляется переменная coef, которой при-
сваивается число 100. Во втором выражении вычисляется произве-
дение переменной coef на десятичный логарифм от переменной d и 
результат затем присваивается вновь переменной d. Как будет ска-
зано ниже, переменная d зарезервирована для обозначения дозы 
элемента. Таким образом, в результате преобразования с использо-
ванием приведенных выражений, доза каждого из элементов будет 
переопределена в соответствии с выражением d=100*log(d). 
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• В конце выражения ставится точка с запятой. 

• Выражения можно писать в строчку оставляя между ними пробелы. 

• Для улучшения читабельности можно вставлять пробелы в любом 
месте выражения. 

• Математические выражения не чувствительны к регистру символов. 
Поэтому, выражения, приведенные в примере ниже эквивалентны 
выражениям из первого примера: 

Coef = 100; d = Coef * Log(D);  

• Аргументы математических функций должны помещаться в круглые 
скобки, как это сделано в примере выше. Список доступных матема-
тических функций обширен и приводится в Help. 

• В выражениях применяются следующие математические операторы: 

+ - сложение или знак плюс; 

- - вычитание или знак минус; 

* - умножение; 

/ - деление; 

^ или ** - возведение в степень. 

• Выражения могут содержать логические операции и включать сле-
дующие логические операторы: 

> - больше 

>= - больше или равно 

< - меньше 

<= - меньше или равно 

<> - не равно 

&& - и 

|| - или 

TRUE - результат логической операции соответствует 1 

FALSE - результат логической операции соответствует 0 

• Следующие символы недопустимы в выражениях: ~ ` % # @ & $ { 
} [ ] " ' ? | \ ! 

• Появление любого из этих символов в выражении приведет к выходу 
из преобразования с соответствующим предупреждением; 

• Предопределенной переменной является круговая константа 
Pi = 3.14159... 

• Следующие переменные зарезервированы в выражениях: 

 D для дозы, A для 3D атрибута, L – для слоя, 

 Zx – фактор растяжения (или сжатия) элемента вдоль оси X 
относительно геометрического центра. Центр вычисляется по 
формуле: (Minx + Maxx)/2. 

 Zy – фактор растяжения (или сжатия) элемента вдоль оси Y 
относительно геометрического центра. Центр вычисляется по 
формуле: (Miny + Maxy)/2. 



Руководство Пользователя Редактор литографических структур 
 

www.nanomaker.com  29 

 Rx – угол поворота элемента относительно оси X вокруг гео-
метрического центра (в градусах). Центр вычисляется по фор-
муле: (Minx + Maxx)/2. 

 Ry - угол поворота элемента относительно оси Y вокруг гео-
метрического центра (в градусах). Центр вычисляется по фор-
муле: (Miny + Maxy)/2. 

 Sx и Sy – для сдвига элемента вдоль оси X  и оси Y, соответст-
венно, (в um) 

 Minx и Maxx – граничные координаты элемента вдоль оси X (в 
um), которые могут быть использованы при трансформации в 
качестве исходных данных. 

 Miny и Maxy – граничные координаты элемента вдоль оси Y (в 
um), которые могут быть использованы при трансформации в 
качестве исходных данных. 

Введенные выражения, для удобства повторного использования, можно 
сохранить в текстовом файле. Для этого нажмите кнопку Save FRM… и в 
открывшемся диалоге Save Formula File задайте имя файла и сохраните. 
Текстовый файл с формулами имеет расширение *.FRM. Чтобы загрузить 
ранее созданные выражения нажмите кнопку Load FRM… и выберите 
нужный файл. 

Нажмите клавишу OK для того чтобы закрыть диалог и выполнить преоб-
разование. 

Разгруппировка (Ungroup) 

Если нужно преобразовать вставку структур(ы) (Structure reference, Dose 
map, Reference map) или Time&Date или Comments в набор составляющих их 
элементов, селектируйте данные вставки/Time&Date/Comments и выберите 
команду меню Edit->Ungroup (или нажмите клавишу U). В случае большого 
количества элементов процедура может занять некоторое время. В этом слу-
чае, в статусной строке появится прогресс-бар, который будет отображать 
процент выполнения. Необходимо отметить, что данная процедура приведет к 
увеличению размера файла данных. 

Проектирование с использованием фонового изображения 

Предположим, что на поверхности вашей подложки уже сформирована неко-
торая структура или существует некоторый рельеф, и вы хотите спроектиро-
вать новые элементы, которые бы вписывались в существующий дизайн. В 
таком случае вам может помочь проектирование с использованием фотогра-
фии в качестве фона (background). Чтобы начать проектирование, нужно по-
лучить изображение интересующего участка поверхности и сохранить его в 
TIFF формате (8 бит/пиксель). Если снимать фотографию с помощью 
NanoMaker'a, тогда можно существенно упростить задачу калибровки полу-
ченного изображения. 

Снимайте изображение в калиброванном поле (Scan field) чтобы сохраняемые 
в тэгах TIFF файла размеры соответствовали реальным. Для съемки изобра-
жения удобно использовать режим "Микроскоп" чтобы сориентировать необ-
ходимым образом фотографируемый объект и задать положение центра, ко-
торое будет точкой привязки изображения к началу координат в окне редак-
тора. 

Вы можете также использовать фотографию, полученную с любого другого 
устройства, но перед использованием ее в редакторе в качестве бэкграунда: 

преобразуйте ее в TIFF формат (8 бит/пиксель); 
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используя диалог Image Processing (Video->Microscope-> Processing…) за-
дайте реальный масштаб, используя знания о действительных размерах объ-
ектов на изображении используя операцию Rescale, и определите центр изо-
бражения с помощью кнопки Set Origin; 

сохраните преобразованное изображение с помощью кнопки Save Image. 

Начните проектирование с того, что откройте новый GDB файл (File->New 
Database) и затем загрузите нужное изображение (View->Redraw-
>Background). Теперь можно начать проектирование, используя фоновое 
изображение в качестве основы для вновь создаваемых элементов (см. Рис. 
13). 

  
Рис. 13. Проектирование с использованием фонового изображения 

Для удобства проектирования яркость фонового изображения можно пони-
зить. Для этого откройте закладку Image в диалоге View Options (Options-
>View->Image tab) и подберите в группе Tone в одном из режимов Auto 
или Manual границу обрезания наиболее ярких пикселей. После закрытия 
диалога View Options, в окне редактора нажмите комбинацию клавиш Alt+C 
чтобы перерисовать окно. 

Сохранение 

По завершению работ результаты проектирования структуры необходимо со-
хранить в GDB файл. Если проектировалась новая структура, или производи-
лись минимальные изменения в существующей структуре, тогда выберите ко-
манду меню File->Save для сохранения данных в уже существующем файле. 
Если изменения были существенными, с большим количеством удаленных и 
вновь созданных элементов, тогда рекомендуется воспользоваться командой 
меню File->Save As и сохранить дизайн в новом GDB файле, что в некоторых 
случаях позволит существенно минимизировать размер файла. 
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ПРОЕКТИРОВАНИЕ ЛИТОГРАФИЧЕСКИХ СТРУКТУР 

Создание структуры дозового клина 

В данном разделе описывается пример проектирования структуры дозового 
клина, которая может быть использована для определения контраста резиста 
(зависимости скорости проявления от дозы экспозиции) и его чувствительно-
сти. Описание метода определения контраста приведено в работе, опублико-
ванной на сайте [1]. 

При создании данной структуры используются приемы редактирования, 
включающие трансформацию элементов посредством формул и задания усло-
вий преобразования в численном виде, которые выбираются командами меню 
Edit->Transform->By Formula и Edit->Transform->Numeric, соответст-
венно. 

Начните проектирование с создания нового GDB файла, выбрав команду ме-
ню File->New Database. При задании параметров в далоге New Database 
File не задавайте сетку разбиения и установите разрешение по умолчанию 1 
нм (см. Рис. 1). Нажмите кнопку OK, после чего будет создан новый файл и 
откроется окно редактора для структуры MAIN. 

 
Рис. 1 Задание параметров нового GDB файла в дилоге New Database File 

Откройте диалог задания атрибутов элементов Attributes командой меню  
Insert->Attributes… и задайте дозу (Dose) равной 100% (см. Рис. 2). За-
кройте диалог Attributes. 

 
Рис. 2 Установка атрибутов вновь создаваемых элементов в диалоге Attributes 

В структуре MAIN создайте прямоугольный элемент с координатами левой-
нижней вершины - 0, 0 μm и правой-верхней - 2, 50 μm, соответственно (см. 
Рис. 3). 
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Рис. 3  Задание параметров численного преобразования в диалоге Numeric Transformation 

С помощью численного преобразования размножьте прямоугольник 101 раз 
по оси Х с приращением дозы каждого последующего прямоугольника на 1%. 
Для этого: 

 селектируйте элемент командой Alt+A; 
 откройте диалог численного преобразования Numeric 

Transformation, выбрав команду меню Edit->Transform->Numeric… 
(или комбинацией клавиш Ctrl+Shif+N); 

 в диалоге задайте число повторов вдоль оси X (Repeat X) равным 101 
с шагом (Step X) 2 μm. Задайте приращение дозы (Dose Increment) 
равным 1% (см. Fig. 3); 

 нажмите клавишу OK, чтобы закрыть диалог и выполнить преобразо-
вание. 

В результате преобразования будет создан массив из 101 примыкающих друг 
к другу прямоугольных элементов, в которых доза d0 (атрибут Dose) возрас-
тает линейно слева направо от 100% в крайнем левом до 200% в крайнем 
правом. 

Для реализации метода определения контраста [1] надо задать такое распре-
деление дозы экспонирования в клине, чтобы после проявления толщина ре-
зиста линейно уменьшалась слева направо от одного его края до другого. Та-
кое нелинейное распределение дозы можно задать с помощью преобразова-
ния по формуле. Поскольку скорость проявления позитивного резиста v про-
порциональна dγ, где γ – его контраст (согласно формуле 1 в [1]), тогда пре-
образование дозы элементов по формуле: 

1
0100*( 1)

100
dd γ= −  

создаст распределение дозы в клине от 0 до 100%. Здесь d0 - исходная доза 
элемента. 
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И, если, реальный контраст резиста будет совпадать с используемой величи-
ной γ, тогда после проявления получится идеальный клин. 

Выполните преобразование доз элементов по формуле, для этого: 

 селектируйте все элементы командой Alt+A; 
 откройте диалог Transform by Formula, выбрав команду меню Edit-

>Transform->By Formula… (или комбинацией клавиш Ctrl+Shif+F); 

 
Рис. 4. Ввод формулы преобразования в диалоге Transform by Formula 

 в диалоге введите следующую формулу: gamma=4;d=100*(d/100-
1)^(1/gamma), где предполагаемая величина контраста gamma равня-
ется 4 (см. Рис. 4); 

 нажмите клавишу OK, чтобы закрыть диалог и выполнить преобразо-
вание. 

 

Дизайн структуры дозового клина в режиме показа дозы приведен на Рис. 5. 

Не забудьте сохранить вновь созданную структуру. 

В упомянутой выше работе [1], для определения контраста были спроектиро-
ваны семь дозовых клиньев для семи значений предполагаемого контраста. 
После экспонирования и проявления (Рис. 6) оказалось, что линейный про-
филь клина достигается для значения контраста, равного 3 (цифра справа). 
Постоянство расстояния между интерференционнами линиями свидетельству-
ет о линейности профиля клина. 
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Рис. 5. Дизайн структуры дозового клина с распределением дозы, заданным посредством 

 преобразования по формуле 

 
Рис. 6 Результирующая структура для определения контраста резиста. О линейности результи-
рующего профиля свидетельствует равное расстояние между интерференционными полосами. 

Ближе всего к этому средний клин, соответствующий контрасту 3. 

 

 

[1] www.nanomaker.com/nav.php?go=paper8 

http://www.nanomaker.com/nav.php?go=paper8
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